Nuance

Support Knowledge Base

Free Online Support
Knowledge Base
Downloads
User's Guides
Hardware Compatibility List
Product Activation
Product Registration
Register online and get more out of your product.
 

Dragon/ViaVoice locks up, freezes or Select-and-Say fails in Microsoft Office applications

Products: Dragon NaturallySpeaking 6, 7, 8, 9, 10; ViaVoice 10;

Problem:

After launching Dragon or ViaVoice and clicking a link in one of the menus, the system locks up or freezes. Other symptoms include Dragon NaturallySpeaking's Select-and-Say or ViaVoice's dictation and commands fail in Microsoft Office XP applications, such as Word and Microsoft Outlook.

Cause:

Microsoft Office XP's "Alternate User Input" installs a background process called CTFMON.exe which can interfere with Dragon or ViaVoice. The following information was taken from the Microsoft website:

"...Ctfmon.exe monitors the active windows and provides text input service support for speech recognition, handwriting recognition, keyboard, translation, and other alternative user input technologies...."

Solution:

Disable CTFMON.exe by following these steps:

Note: Close out of all applications and end the "ctfmon.exe" process in the Task Manager before completing the following steps (if it is running).

STEP ONE: Remove "ctfmon.exe" from the computers start up.

    Windows 98, ME, and XP:
  1. Close all open applications.
  2. Click "Start > Run".
  3. Type "msconfig" without the quotes into the "Run" dialog box.
  4. Click "OK".
  5. Under the "Start Up" tab look for "ctfmon.exe" and uncheck it.
  6. Click "Apply" and "OK".
  7. Restart the computer.
    Windows NT, and 2000:

    ************* Registry Backup Recommended *************

    IMPORTANT: This section contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. Follow the steps below to back up the registry:

    1. Open the Registry Editor by clicking "Start > Run". Type in "regedit" without the quotes and click "OK".
    2. Export a backup copy of your Registry in case problems occur during the following procedures by going to:
      • Windows 98SE, 2000, and ME: Registry menu > Export registry file.
      • Windows XP: File > Export Registry File.
    3. Save this file to the Windows Desktop and name the file "backup". (You can keep "backup" for a few days and if all is well, this file can be deleted.)

    ************* End of Registry Backup *************

    Editing the registry on Windows NT and 2000:
  1. Click "Start > Run".
  2. Type "regedit" without the quotes in the "Run" dialog box.
  3. Click "OK"
  4. Browse to the following keys and delete "ctfmon.exe" from the right window pane:
    • HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run
    • HKEY_LOCAL_MACHINE\ Software\Microsoft\Windows\CurrentVersion\Run
  5. Close the "Registry Editor".
  6. Restart the computer.

STEP TWO: Uninstall Alternative User Input

    Windows Me, 98 and NT 4.0:
  1. Close all open applications, including AntiVirus software.
  2. Click "Start > Settings > Control Panel."
  3. Under "Add/Remove Programs" > "Install/Uninstall" tab, select "Microsoft Office XP." If you're using a single version of an Office application, select it in the list.
  4. Click the "Add/Remove" button to access the Microsoft Office installer.
  5. In the next screen, choose "Add or Remove Features," and click "Next."
  6. If using Microsoft Word 2002, choose "Shared Office Features" and click next. If using Microsoft Word 2003, place a "check" in the "Choose advanced customization of applications" option and click "Next."


    1. Expand "Microsoft Office".
    2. Expand "Microsoft Office Excel", click the symbol next to "Text to Speech", and then click "Not Available".
    3. Expand "Office Shared Features".
    4. Expand "Alternative User Input".
    5. Click the symbol next to "Speech", and then click "Not Available".
    6. Click the symbol next to "Handwriting", and then click "Not Available".
    7. Click the symbol next to "Microsoft Handwriting Component”, and then click "Not Available".
    8. Expand "Proofing Tools".
    9. Expand "French", click the symbol next to "English - French Translation", and then click "Not Available".
    10. Expand "Spanish", click the symbol next to “English - Spanish Translation", and then click "Not Available".

  7. Click "Update."
    Windows 2000 or XP:
  1. Close all open applications, including AntiVirus software.
  2. Click "Start > Settings > Control Panel." (or "Start > Control Panel" in Windows XP)
  3. Under "Add/Remove Programs" > "Change or Remove Programs", select "Microsoft Office XP." If you're using a single version of an Office application, select it in the list.
  4. Click the "Change" button to access the Microsoft Office installer.
  5. In the next screen choose "Add or Remove Features," and click "Next."
  6. If using Microsoft Word 2003; place a "check" in the "Choose advanced customization of applications" option and click "Next."


    1. Expand "Microsoft Office".
    2. Expand "Microsoft Office Excel", click the symbol next to "Text to Speech", and then click "Not Available".
    3. Expand "Office Shared Features".
    4. Expand "Alternative User Input”.
    5. Click the symbol next to "Speech", and then click "Not Available".
    6. Click the symbol next to "Handwriting", and then click “Not Available".
    7. Click the symbol next to "Microsoft Handwriting Component", and then click "Not Available".
    8. Expand "Proofing Tools".
    9. Expand "French", click the symbol next to "English - French Translation", and then click "Not Available".
    10. Expand "Spanish", click the symbol next to "English - Spanish Translation", and then click "Not Available".

  7. Click "Update."

  8. Reboot Computer

Additional Information:

If the Microsoft speech utility is enabled by the operating system, use the following steps to remove the Alternative User Input Services from the Text Services:

  1. Click "Start > Settings > Control Panel."
  2. Click "Regional and Language Options > Languages tab > Details button > Advanced tab."
  3. Under "System Configuration," check the box that says Turn off advanced text services.
  4. Under "Installed services", click "Speech Recognition", click "Remove", and then click "OK".
  5. Click OK in each dialog box to close it.

Note: Turning off advanced text services will disable handwriting recognition. There is an alternative method of turning off the advanced text services within Dragon NaturallySpeaking 10. Scroll down to the *** Dragon Only *** section for more information.

*************** Proceed to Step 3 if ctfmon.exe still appears in the process list after rebooting the computer ***************

STEP THREE: Unregister the Msctf.dll Files and Msimtf.dll Files

Click "Start > Run."

  1. In the Run dialog box type:

    regsvr32 /u msimtf.dll

    Click "OK."
    Click "Start > Run."

  2. In the Run dialog box type:

    regsvr32 /u msctf.dll

    Click "OK."

    Confirm that CTFMON.exe is not showing as a process when you press Control+Alt+Delete (Task Manager).

*** FOR DRAGON ONLY ***

Disabling Windows advanced text services from within Dragon NaturallySpeaking 10 (This option does not appear on systems running Windows Vista.):

Dragon NaturallySpeaking 10 provides the ability to disable CTFMON.exe directly from Administrative Settings dialog.

  1. From the DragonBar, "File > Close User".
  2. Click "Tools > Administrative Settings".
  3. Click the "Miscellaneous" tab.
  4. Enable the option "Disable Windows Advanced text services".
  5. Click "OK" to apply the changes.

Another possibility is to re-enable "dgnword.dll" for Select-and-Say to work in Microsoft Word. These steps are outlined in Technote # 3059.

Some of the information for this Technote was taken from the Microsoft Website at www.microsoft.com

TechNote Number: 3118
Published: 06/25/2002
Last Modified: 2/19/2009

THE ORIGIN OF THE INFORMATION BEING PROVIDED IN THESE TECH NOTES MAY BE INTERNAL OR EXTERNAL TO NUANCE. NUANCE MAKES REASONABLE EFFORTS TO VERIFY THIS INFORMATION. NUANCE MAKES THESE TECH NOTES AVAILABLE TO YOU FOR YOUR INFORMATION ONLY. NUANCE PROVIDES THESE TECH NOTES "AS IS" AND MAKES NO REPRESENTATIONS OR WARRANTIES CONCERNING THEM, INCLUDING ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, OR NON-INFRINGEMENT. IN NO EVENT WILL NUANCE BE LIABLE FOR ANY ERRORS CONTAINED HEREIN OR FOR ANY SPECIAL, INDIRECT, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OR ANY OTHER DAMAGES WHATSOEVER IN CONNECTION WITH THE FURNISHING, PERFORMANCE OR USE OF THESE TECH NOTES. THE TECH NOTES AVAILABLE HEREIN ARE SUBJECT TO REVISION OR CHANGE WITHOUT NOTICE.

© 2005 Nuance Communications, Inc. All rights reserved.